From: Jeff King Date: Thu, 21 May 2020 18:35:36 GMT Subject: Re: [PATCH v2 0/4] t: replace incorrect test_must_fail usage (part 5) Message-ID: <20200521183536.GA1308489@coredump.intra.peff.net> In-Reply-To: On Thu, May 21, 2020 at 09:47:22AM -0700, Junio C Hamano wrote: > Denton Liu writes: > > > Hi all, > > > > This is mostly a resend of what's currently queued in > > "dl/test-must-fail-fixes-5" except with a tiny bit of cleanup on the tip > > patch. I'd appreciate a review on this series so that we can finally get > > rid of that "Needs review" on the What's Cooking messages ;) > > Thanks. > > The OVERWRITING_FAIL one was the only one I was unhappy about, so it > would be good to have more eyeballs on it---perhaps other people > find the approach acceptable, or can suggest more readable and > understandable approach. FWIW, I don't really like it either. :) I gave my best shot at an alternative in reply to that patch. -Peff