From: Damien Robert Date: Thu, 12 Mar 2020 17:09:28 GMT Subject: [PATCH v2 0/3] Documentation of pack and repack Message-ID: <20200312170931.2392490-1-damien.olivier.robert+git@gmail.com> In-Reply-To: <20200228154357.1710521-2-damien.olivier.robert+git@gmail.com> The first patch is a small clean up I found when reading the source to try to understand the behaviour of pack-objects when writing the documentation. The second patch update the documentation. These two are not changed from my previous round, except - I changed the order - I took into account the typos mentioned by Junio - I removed the default options section which referred to the default options passed to `git pack-objects` by `git repack` In particular in the second patch the only update to the options description in git repack is still 'are passed to `git pack-objects`'. I added a third patch that add some quick description of the options -l, -f, -F and -q. Damien Robert (3): pack-objects: change the name of add_objects_in_unpacked_packs doc: update the documentation of pack-objects and repack doc: add a short explanation for git-repack options Documentation/git-pack-objects.txt | 27 +++++++++---- Documentation/git-repack.txt | 62 +++++++++++++++++++----------- builtin/pack-objects.c | 4 +- 3 files changed, 61 insertions(+), 32 deletions(-) -- Patched on top of v2.26.0-rc1-6-ga56d361f66 (git version 2.25.1)