From: Jeff King Date: Mon, 24 Feb 2020 18:23:51 GMT Subject: Re: [PATCH 01/10] nth_packed_object_oid(): use customary integer return Message-ID: <20200224182351.GA2182592@coredump.intra.peff.net> In-Reply-To: <20200224042736.GA1018190@coredump.intra.peff.net> On Sun, Feb 23, 2020 at 11:27:37PM -0500, Jeff King wrote: > Since we are changing the interface in a subtle way that the compiler > wouldn't catch, let's also change the name to catch any topics in > flight. We can drop the 'o' and make it nth_packed_object_id(). That's > slightly shorter, but also less redundant since the 'o' stands for > "object" already. Note that this does catch one topic that's in next: jk/object-filter-with-bitmap. Since the newly added call there doesn't check the return value, it just needs s/oid/id/ in the function name. -Peff