From: Jeff King Date: Fri, 05 Apr 2019 18:16:31 GMT Subject: Re: [PATCH v2 09/13] server-info: simplify cleanup in parse_pack_def() Message-ID: <20190405181630.GA2284@sigill.intra.peff.net> In-Reply-To: <20190405181313.GI32243@sigill.intra.peff.net> On Fri, Apr 05, 2019 at 02:13:13PM -0400, Jeff King wrote: > Subject: server-info: simplify cleanup in parse_pack_def() > We have two exits from the function: either we jump to the out_stale > label or not. But in both exits we repeat our cleanup, and the only > difference is our return value. Let's just use a variable for the return > value to avoid repeating ourselves. The subject name is misleading here. The change is actually in read_pack_info_file(), which sees an error when calling parse_pack_def(). Probably not worth a re-roll by itself. -Peff