From: Jeff King Date: Wed, 05 Dec 2018 04:57:15 GMT Subject: Re: [PATCH 1/3] test-lib: consolidate naming of test-results paths Message-ID: <20181205045714.GC12284@sigill.intra.peff.net> In-Reply-To: <20181204163457.15717-2-szeder.dev@gmail.com> On Tue, Dec 04, 2018 at 05:34:55PM +0100, SZEDER Gábor wrote: > There are two places where we strip off any leading path components > and the '.sh' suffix from the test script's pathname, and there are > two places where we construct the filename of test output files in > 't/test-results/'. The last patch in this series will add even more. > > Factor these out into helper variables to avoid repeating ourselves. Makes sense. > +TEST_NAME="$(basename "$0" .sh)" > +TEST_RESULTS_BASE="$TEST_OUTPUT_DIRECTORY/test-results/$TEST_NAME" Hmm, since we are building up this BASE variable anyway, why not: TEST_RESULTS_DIR=$TEST_OUTPUT_DIRECTORY/test-results TEST_RESULTS_BASE=$TEST_RESULTS_DIR/$TEST_NAME ? That saves having to run `dirname` on it later. I guess one could argue that saying "the directory name of the file I'm writing" is more readable. I just generally try to avoid extra manipulation of the strings when possible (especially in shell). -Peff