From: Phillip Wood Date: Thu, 18 Oct 2018 10:00:18 GMT Subject: [PATCH v2 0/5] am/rebase: share read_author_script() Message-ID: <20181018100023.7327-1-phillip.wood@talktalk.net> In-Reply-To: <20180912101029.28052-1-phillip.wood@talktalk.net> From: Phillip Wood Thanks to Eric for his feedback on v1. I've rerolled based on that. Patches 1 & 2 are new and try to address some of the concerns Eric raised, particularly the error handling for a badly edited author script. See the notes on patches 4 & 5 for the changes to those (they were previously 2 & 3). v1 cover letter: This is a follow up to pw/rebase-i-author-script-fix, it reduces code duplication and improves rebase's parsing of the author script. After this I'll do another series to share the code to write the author script. Phillip Wood (5): am: don't die in read_author_script() am: improve author-script error reporting am: rename read_author_script() add read_author_script() to libgit sequencer: use read_author_script() builtin/am.c | 60 ++-------------- sequencer.c | 192 ++++++++++++++++++++++++++++++++------------------- sequencer.h | 3 + 3 files changed, 128 insertions(+), 127 deletions(-) -- 2.19.0