From: Jeff King Date: Mon, 21 May 2018 21:52:16 GMT Subject: Re: [PATCH v2 02/18] Add a new builtin: branch-diff Message-ID: <20180521215216.GB16623@sigill.intra.peff.net> In-Reply-To: <20180521214057.GB125693@google.com> On Mon, May 21, 2018 at 02:40:57PM -0700, Brandon Williams wrote: > > > > Most fellow German software engineers (who seem to have a knack for > > > > idiotically long variable/function names) would now probably suggest: > > > > > > > > git compare-patch-series-with-revised-patch-series > > > > > > or short: > > > > > > revision-compare > > > compare-revs > > > com-revs > > > > > > revised-diff > > > revise-diff > > > revised-compare > > > > > > diff-revise > > I haven't really been following all of the discussion but from what I > can tell the point of this command is to generate a diff based on two > different versions of a series, so why not call it 'series-diff'? :) That's OK with me, though I prefer "range" as I think we use that term elsewhere ("series" is usually part of "patch series", but many people do not use a workflow with that term). -Peff