From: Jeff King Date: Sat, 31 Mar 2018 10:13:47 GMT Subject: Re: [PATCH v7 10/13] pack-objects: clarify the use of object_entry::size Message-ID: <20180331101347.GA32290@sigill.intra.peff.net> In-Reply-To: On Sat, Mar 31, 2018 at 06:35:40AM +0200, Duy Nguyen wrote: > On Fri, Mar 30, 2018 at 11:04 PM, Jeff King wrote: > > The subject says "clarify" so I was a little surprised to see code > > changes. It looks like we're just avoiding reassigning on top of the > > value repeatedly, which is part of that clarification. It looks like a > > noop to me. > > Oh well... I was counting on the new name (in_pack_size, which follows > in_pack_type naming convention) to emphasize it (and the new "delta > size" comment to point out where in_pack_size contains a delta size. Just to be clear, my final "it looks like a noop" means "good, it looks like it is a pure cosmetic change and no change to the behavior." -Peff