From: brian m. carlson Date: Sun, 29 Oct 2017 19:33:28 GMT Subject: Re: [PATCH v2 3/4] Integrate hash algorithm support with repo setup Message-ID: <20171029193327.uqkj6w3ypfwqwm7b@genre.crustytoothpaste.net> In-Reply-To: On Sun, Oct 29, 2017 at 03:02:20PM -0400, Eric Sunshine wrote: > On Sun, Oct 29, 2017 at 1:57 PM, brian m. carlson > wrote: > > I can do CURRENT_HASH_ALGO or CURRENT_HASH instead if you think that's > > an improvement. I originally omitted the "algo" portion to keep it > > short. > > I don't have strong feelings about it aside from worrying about a > "current_hash" name clash or a reader misunderstanding what it > represents. > > Does "current" need to be in the name? What about HASH_ALGO or REPO_HASH_ALGO? > > > Alternatively, we could have a current_hash() (or current_hash_algo()) > > inline function if people like that better. > > hash_algo() or repo_hash_algo()? Those are also fine, and shorter to boot. I'll wait to see if anyone has strong opinions on the direction we should go before making a change. -- brian m. carlson / brian with sandals: Houston, Texas, US https://www.crustytoothpaste.net/~bmc | My opinion only OpenPGP: https://keybase.io/bk2204