From: Jonathan Nieder Date: Mon, 25 Sep 2017 22:16:08 GMT Subject: Re: [PATCH 7/7] add xread_in_full() helper Message-ID: <20170925221608.GF27425@aiede.mtv.corp.google.com> In-Reply-To: <20170925203323.rmm3i5kx266ma3wu@sigill.intra.peff.net> Jeff King wrote: > Many callers of read_in_full() expect to see exactly "len" > bytes, and die if that isn't the case. micronit: Can this be named read_in_full_or_die? Otherwise it's too easy to mistake for a function like xread, which has different semantics. I realize that xmalloc, xmemdupz, etc use a different convention. That's yet another reason to be explicit, IMHO. Thanks, Jonathan