From: Jeff King Date: Wed, 06 Sep 2017 12:30:28 GMT Subject: [PATCH 1/2] system_path: move RUNTIME_PREFIX to a sub-function Message-ID: <20170906123027.w5y7s33p5p2kfzia@sigill.intra.peff.net> In-Reply-To: <20170906122834.s7a6je4b7casdfxx@sigill.intra.peff.net> The system_path() function has an #ifdef in the middle of it. Let's move the conditional logic into a sub-function. This isolates it more, which will make it easier to change and add to. Signed-off-by: Jeff King --- I find the diff hard to read because it shows the opposite of what I did (moving the big block to its own function, rather than moving the little bits to a new copy of the function). exec_cmd.c | 33 +++++++++++++++++++++------------ 1 file changed, 21 insertions(+), 12 deletions(-) diff --git a/exec_cmd.c b/exec_cmd.c index fb94aeba9c..61092e9715 100644 --- a/exec_cmd.c +++ b/exec_cmd.c @@ -7,19 +7,12 @@ static const char *argv_exec_path; static const char *argv0_path; -char *system_path(const char *path) -{ #ifdef RUNTIME_PREFIX - static const char *prefix; -#else - static const char *prefix = PREFIX; -#endif - struct strbuf d = STRBUF_INIT; - if (is_absolute_path(path)) - return xstrdup(path); +static const char *system_prefix(void) +{ + static const char *prefix; -#ifdef RUNTIME_PREFIX assert(argv0_path); assert(is_absolute_path(argv0_path)); @@ -32,9 +25,25 @@ char *system_path(const char *path) "but prefix computation failed. " "Using static fallback '%s'.\n", prefix); } -#endif + return prefix; +} +#else + +static const char *system_prefix(void) +{ + return PREFIX; +} + +#endif /* RUNTIME_PREFIX */ + +char *system_path(const char *path) +{ + struct strbuf d = STRBUF_INIT; + + if (is_absolute_path(path)) + return xstrdup(path); - strbuf_addf(&d, "%s/%s", prefix, path); + strbuf_addf(&d, "%s/%s", system_prefix(), path); return strbuf_detach(&d, NULL); } -- 2.14.1.757.g8fad538cea