From: Jeff King Date: Sun, 16 Jul 2017 10:27:04 GMT Subject: Re: [PATCH 2/1] bswap: convert get_be16, get_be32 and put_be32 to inline functions Message-ID: <20170716102704.2yywbidmmjv7zfxh@sigill.intra.peff.net> In-Reply-To: <06c5bc39-d2c4-3436-97a7-9faa7c0519ca@web.de> On Sat, Jul 15, 2017 at 09:22:50PM +0200, René Scharfe wrote: > Simplify the implementation and allow callers to use expressions with > side-effects by turning the macros get_be16, get_be32 and put_be32 into > inline functions. > > Signed-off-by: Rene Scharfe > --- > All these redundant casts started to bother me, so I tried to come up > with nice and clean inline functions. Successfully? You tell me. > They are longer, but less cluttered. Would it punish -O0 builds? Is > it all worth it? I do think the end result is a lot more readable. On gcc 6 at least, the function seems[1] to end up inlined even with -O0. Interestingly, at -O2 even with -DNO_UNALIGNED_LOADS, gcc converts the result to a movl and a bswap. Which is the same thing our unaligned-loads path is trying for. I wonder if we could/should just drop it (that _would_ punish -O0 on x86, though). -Peff