From: Jeff King Date: Fri, 26 May 2017 19:07:42 GMT Subject: [PATCH 3/6] check_filename(): use skip_prefix Message-ID: <20170526190742.d53haiwyr3uegbub@sigill.intra.peff.net> In-Reply-To: <20170526190607.jr44oygs6mzm3q6e@sigill.intra.peff.net> This avoids some magic numbers (and we'll be adding more similar calls in a minute). Signed-off-by: Jeff King --- setup.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/setup.c b/setup.c index 000ffa810..f2a8070bd 100644 --- a/setup.c +++ b/setup.c @@ -137,10 +137,9 @@ int check_filename(const char *prefix, const char *arg) char *to_free = NULL; struct stat st; - if (starts_with(arg, ":/")) { - if (arg[2] == '\0') /* ":/" is root dir, always exists */ + if (skip_prefix(arg, ":/", &arg)) { + if (!*arg) /* ":/" is root dir, always exists */ return 1; - arg += 2; prefix = NULL; } -- 2.13.0.496.ge44ba89db