From: Brandon Williams Date: Tue, 03 Jan 2017 17:58:46 GMT Subject: Re: What's cooking in git.git (Dec 2016, #08; Tue, 27) Message-ID: <20170103175846.GA42671@google.com> In-Reply-To: On 01/03, Duy Nguyen wrote: > On Thu, Dec 29, 2016 at 5:06 PM, Duy Nguyen wrote: > > On Thu, Dec 29, 2016 at 1:18 AM, Brandon Williams wrote: > >> On 12/27, Junio C Hamano wrote: > >>> * bw/pathspec-cleanup (2016-12-14) 16 commits > >>> - pathspec: rename prefix_pathspec to init_pathspec_item > >>> - pathspec: small readability changes > >>> - pathspec: create strip submodule slash helpers > >>> - pathspec: create parse_element_magic helper > >>> - pathspec: create parse_long_magic function > >>> - pathspec: create parse_short_magic function > >>> - pathspec: factor global magic into its own function > >>> - pathspec: simpler logic to prefix original pathspec elements > >>> - pathspec: always show mnemonic and name in unsupported_magic > >>> - pathspec: remove unused variable from unsupported_magic > >>> - pathspec: copy and free owned memory > >>> - pathspec: remove the deprecated get_pathspec function > >>> - ls-tree: convert show_recursive to use the pathspec struct interface > >>> - dir: convert fill_directory to use the pathspec struct interface > >>> - dir: remove struct path_simplify > >>> - mv: remove use of deprecated 'get_pathspec()' > >>> > >>> Code clean-up in the pathspec API. > >>> > >>> Waiting for the (hopefully) final round of review before 'next'. > >> > >> What more needs to be reviewed for this series? > > > > I wanted to have a look at it but I successfully managed to put if off > > so far. Will do soonish. > > I have just sent a couple of minor comments. The rest looks good! Thanks! I'll go take a look. -- Brandon Williams