From: Jeff King Date: Mon, 15 Feb 2016 18:36:22 GMT Subject: Re: [PATCH 1/4] remote: use skip_prefix Message-ID: <20160215183622.GA27244@sigill.intra.peff.net> In-Reply-To: On Mon, Feb 15, 2016 at 01:35:03PM -0500, Eric Sunshine wrote: > On Mon, Feb 15, 2016 at 1:18 PM, Jeff King wrote: > > This is definitely an improvement, but I think we can actually go a step > > further here, and use parse_config_key. Like: > > > > - if (starts_with(key, "branch.")) { > > - name = key + 7; > > - subkey = strrchr(name, '.'); > > - if (!subkey) > > + if (starts_with(key, "branch", &name, &namelen, &subkey)) { > > I guess you meant: s/starts_with/parse_config_key/ Whoops, yeah. I'll belatedly add a "not even compile-tested" disclaimer. :) -Peff