From: Jeff King Date: Sat, 05 Dec 2015 07:01:37 GMT Subject: Re: [PATCH 2/3] add is_git_repo (is_git_repository for char*) Message-ID: <20151205070137.GB21639@sigill.intra.peff.net> In-Reply-To: <1449252917-3877-2-git-send-email-a.krey@gmx.de> On Fri, Dec 04, 2015 at 07:15:16PM +0100, Andreas Krey wrote: > diff --git a/cache.h b/cache.h > index 6626e97..42ab0c3 100644 > --- a/cache.h > +++ b/cache.h > @@ -440,6 +440,7 @@ extern const char *get_git_dir(void); > extern const char *get_git_common_dir(void); > extern int is_git_directory(const char *path); > extern int is_git_repository(struct strbuf *sb); > +extern int is_git_repo(const char *path); If we have two functions which do the same thing but differ only in their interface (here strbuf versus a C-string), we should probably give them related names that indicate the difference. So "is_git_repository_str()" or something. (though per my previous email, I think we should have a new name for the first one, too). -Peff