From: Jeff King Date: Tue, 01 Sep 2015 22:41:35 GMT Subject: Re: [PATCH v2 3/6] t6300: introduce test_date() helper Message-ID: <20150901224135.GH7862@sigill.intra.peff.net> In-Reply-To: <20150901224013.GJ30659@serenity.lan> On Tue, Sep 01, 2015 at 11:40:13PM +0100, John Keeping wrote: > > I notice we end up with rather long lines for some of these. Would: > > > > test_date "" <<-\EOF > > Mon Jul 3 17:18:43 2006 +0200 > > Mon Jul 3 17:18:44 2006 +0200 > > Mon Jul 3 17:18:45 2006 +0200 > > EOF > > > > be more readable? > > We could just do: > > test_date "" \ > "Tue Jul 4 01:18:43 2006 +0200" \ > "Tue Jul 4 01:18:44 2006 +0200" \ > "Tue Jul 4 01:18:45 2006 +0200" > > I'm not entirely sure why I didn't now that I look at it! Yeah, that also looks good, and is probably less confusing that the here-doc. -Peff