From: Jeff King Date: Thu, 20 Aug 2015 14:45:04 GMT Subject: Re: [PATCH] config: restructure format_config() for better control flow Message-ID: <20150820144504.GA22935@sigill.intra.peff.net> In-Reply-To: <1440080062-26811-1-git-send-email-szeder@ira.uka.de> On Thu, Aug 20, 2015 at 04:14:22PM +0200, SZEDER Gábor wrote: > Commit 578625fa91 (config: add '--name-only' option to list only > variable names, 2015-08-10) modified format_config() such that it > returned from the middle of the function when showing only keys, > resulting in ugly code structure. > > Reorganize the if statements and dealing with the key-value delimiter to > make the function easier to read. This looks good to me. What do you think of these on top? [1/3]: format_config: don't init strbuf [2/3]: format_config: simplify buffer handling [3/3]: get_urlmatch: avoid useless strbuf write -Peff