From: Jonathan Nieder Date: Fri, 13 Jun 2014 21:05:42 GMT Subject: Re: [PATCH 1/2] blame: factor out get_next_line() Message-ID: <20140613210542.GK8557@google.com> In-Reply-To: <539B569F.1090800@web.de> René Scharfe wrote: > Signed-off-by: Rene Scharfe > --- > builtin/blame.c | 28 ++++++++++------------------ > 1 file changed, 10 insertions(+), 18 deletions(-) Reviewed-by: Jonathan Nieder [...] > + for (p = get_next_line(buf, end); p; p = get_next_line(p, end)) > + num++; This could say something like for (p = buf; p = get_next_line(buf, end); ) { num++; or p = buf; while ((p = memchr(p, '\n', end - p))) { p++; num++; } but what you have seems more readable. Thanks, Jonathan