From: Jeff King Date: Wed, 05 Feb 2014 17:26:51 GMT Subject: Re: [PATCH 0/3] Add a function skip_prefix_if_present() Message-ID: <20140205172651.GC7268@sigill.intra.peff.net> In-Reply-To: <52F1E04D.3090208@alum.mit.edu> On Wed, Feb 05, 2014 at 07:55:09AM +0100, Michael Haggerty wrote: > * René Scharfe submitted a patch to use a function parse_prefix() > (originally suggested by Peff) instead of Duy's suggested approach: > > http://article.gmane.org/gmane.comp.version-control.git/239569 > > His patch appears to have been overlooked. > > * Duy seemed to offer to rewrite his patch series, but I don't think > that it has happened yet. > > And then the conversation was drowned by Christmas eggnog. > > I don't have a strong feeling about (Duy's proposal plus my patches) vs. > (René's parse_prefix() approach). But I definitely *do* like the idea > of getting rid of all those awkward magic numbers everywhere. FWIW, after coming down off my eggnog bender, I think I still prefer René's (my?) approach. -Peff