From: Jeff King Date: Fri, 21 Jun 2013 18:03:34 GMT Subject: Re: HTTP tests fail on OS X Message-ID: <20130621180334.GA4499@sigill.intra.peff.net> In-Reply-To: On Fri, Jun 21, 2013 at 01:03:40PM -0400, Brian Gernhardt wrote: > On Jun 21, 2013, at 12:49 AM, Jeff King wrote: > > > I'm not sure what else to look at...I guess try ratcheting up the > > debugging/log level on your failing copy and see if it prints anything > > useful. > > I found this error in the error.log: > > [Fri Jun 21 12:59:59 2013] [emerg] (2)No such file or directory: Couldn't create accept lock (/private/var/run/accept.lock.64288) (5) Hmm. I am far from an apache expert, but I believe that is what would happen if the LockFile directive was not there at all. IOW, it seems like your apache is treating "" as false. Which seems weird to me. It's possible I'm using IfVersion wrong, though it does seem to work for me elsewhere. IfVersion comes from mod_version. I assume that if it were not loaded, apache would complain about the directive entirely. But it's true that we don't load it until later. Maybe try moving the IfVersion/Lockfile stanza down below the mod_version LoadModule line? -Peff