From: Jeff King Date: Mon, 10 Jun 2013 05:05:26 GMT Subject: Re: [PATCH v2 1/4] toposort: rename "lifo" field Message-ID: <20130610050526.GC3621@sigill.intra.peff.net> In-Reply-To: <1370820277-30158-2-git-send-email-gitster@pobox.com> On Sun, Jun 09, 2013 at 04:24:34PM -0700, Junio C Hamano wrote: > The name "lifo", however, is too strongly tied to the way how the > function implements its behaviour, and does not describe what the > behaviour _means_. > > Replace this field with an enum rev_sort_order, with two possible > values: REV_SORT_IN_GRAPH_ORDER and REV_SORT_BY_COMMIT_DATE, and > update the existing code. The mechanical replacement rule is: > > "lifo == 0" is equivalent to "sort_order == REV_SORT_BY_COMMIT_DATE" > "lifo == 1" is equivalent to "sort_order == REV_SORT_IN_GRAPH_ORDER" Thanks. Having looked at this code for the first time in a long time recently, I was very confused by the purpose of the "lifo" flag; this patch would have made it much clearer. Patch itself looks fine to me. -Peff