From: Jeff King Date: Fri, 22 Mar 2013 14:58:03 GMT Subject: Re: [PATCH 3/6] t5516 (fetch-push): introduce mk_test_with_name() Message-ID: <20130322145803.GC3083@sigill.intra.peff.net> In-Reply-To: <7vip4j8oz5.fsf@alter.siamese.dyndns.org> On Fri, Mar 22, 2013 at 07:54:06AM -0700, Junio C Hamano wrote: > Ramkumar Ramachandra writes: > > > mk_empty () { > > - rm -fr testrepo && > > - mkdir testrepo && > > + repo_name="$1" > > + test -z "$repo_name" && repo_name=testrepo > > + rm -fr $repo_name && > > + mkdir $repo_name && > > Your quoting is sloppy in this entire patch X-<. I meant to mention that, too. It doesn't matter, as the intent is for it always to be a simple name like "testrepo", but that assumption is not documented anywhere. I suspect the quoting in my patch is sloppy, too. -Peff