From: Jonathan Nieder Date: Wed, 20 Mar 2013 18:22:13 GMT Subject: Re: [PATCH 2/6] t5516 (fetch-push): update test description Message-ID: <20130320182213.GI3655@google.com> In-Reply-To: <1363783501-27981-3-git-send-email-artagnon@gmail.com> Ramkumar Ramachandra wrote: > --- a/t/t5516-fetch-push.sh > +++ b/t/t5516-fetch-push.sh > @@ -1,6 +1,6 @@ > #!/bin/sh > > -test_description='fetching and pushing, with or without wildcard' > +test_description='fetching and pushing' I'm not thrilled with the description before or after. Would it make sense to do something like the following? test_description='Tests of basic fetch/push functionality. These tests create small test repositories and fetch from and push to them, testing: * commandline syntax * refspecs and default refspecs * fast-forward detection and overriding fast-forward detection * configuration (insteadOf, pushInsteadOf, [remote "name"] push, etc) * hooks * --porcelain output format * hiderefs '