From: Jeff King Date: Mon, 18 Feb 2013 10:29:31 GMT Subject: Re: [PATCHv2 05/10] pkt-line: rename s/packet_read_line/packet_read/ Message-ID: <20130218102931.GP5096@sigill.intra.peff.net> In-Reply-To: <20130218101915.GE7049@elie.Belkin> On Mon, Feb 18, 2013 at 02:19:15AM -0800, Jonathan Nieder wrote: > Jeff King wrote: > > > Originally packets were used just for the line-oriented ref > > advertisement and negotiation. These days, we also stuff > > packfiles and sidebands into them, and they do not > > necessarily represent a line. Drop the "_line" suffix, as it > > is not informative and makes the function names quite long > > (especially as we add "_gently" and other variants). > > > > Signed-off-by: Jeff King > > --- > > Again, this is a taste issue. Can be optional. > > In combination with patch 3, this changes the meaning of packet_read() > without changing its signature, which could make other patches > cherry-picked on top change behavior in unpredictable ways. :( > > So I'd be all for this if the signature changes (for example to put > the fd at the end or something), but not so if not. True. Though packet_read has only existed since last June, only had one callsite (which would now conflict, since I'm touching it in this series), and has no new calls in origin..origin/pu. So it's relatively low risk for such a problem. I don't know how careful we want to be. -Peff