From: Jonathan Nieder Date: Mon, 18 Feb 2013 10:19:15 GMT Subject: Re: [PATCHv2 05/10] pkt-line: rename s/packet_read_line/packet_read/ Message-ID: <20130218101915.GE7049@elie.Belkin> In-Reply-To: <20130218092252.GE5096@sigill.intra.peff.net> Jeff King wrote: > Originally packets were used just for the line-oriented ref > advertisement and negotiation. These days, we also stuff > packfiles and sidebands into them, and they do not > necessarily represent a line. Drop the "_line" suffix, as it > is not informative and makes the function names quite long > (especially as we add "_gently" and other variants). > > Signed-off-by: Jeff King > --- > Again, this is a taste issue. Can be optional. In combination with patch 3, this changes the meaning of packet_read() without changing its signature, which could make other patches cherry-picked on top change behavior in unpredictable ways. :( So I'd be all for this if the signature changes (for example to put the fd at the end or something), but not so if not. Thanks, Jonathan