From: Jeff King Date: Sun, 04 Nov 2012 11:41:01 GMT Subject: Re: [PATCH 1/4] strbuf_split_buf(): use ALLOC_GROW() Message-ID: <20121104114101.GA336@sigill.intra.peff.net> In-Reply-To: <1352011614-29334-2-git-send-email-mhagger@alum.mit.edu> On Sun, Nov 04, 2012 at 07:46:51AM +0100, Michael Haggerty wrote: > Use ALLOC_GROW() rather than inline code to manage memory in > strbuf_split_buf(). Rename "pos" to "nr" because it better describes > the use of the variable and it better conforms to the "ALLOC_GROW" > idiom. I suspect this was not used originally because ALLOC_GROW relies on alloc_nr, which does fast growth early on. At (x+16)*3/2, we end up with 24 slots for the first allocation. We are typically splitting 1 or 2 values. It probably doesn't make a big difference in practice, though, as we're talking about wasting less than 200 bytes on a 64-bit platform, and we do not tend to keep large numbers of split lists around. -Peff