From: Jeff King Date: Mon, 10 Sep 2012 20:01:10 GMT Subject: Re: Probable bug in file run-command.c function clear_child_for_cleanup Message-ID: <20120910200110.GA32437@sigill.intra.peff.net> In-Reply-To: <7v8vchodgc.fsf@alter.siamese.dyndns.org> On Mon, Sep 10, 2012 at 01:00:35PM -0700, Junio C Hamano wrote: > >> And to conclude my bikeshedding for the day: Shouldn't "last" ideally > >> be called something like "prev" instead? It's the previously visited > >> element, not the last element in the list. > > > > It is the "last" element visited (just as "last week" is not the end of > > the world), but yes, it is ambiguous, and "prev" is not. Either is fine > > by me. > > OK, so who's gonna do the honors? I was hoping to give David a chance to submit his first-ever patch to git. -Peff