From: Jeff King Date: Mon, 10 Sep 2012 14:10:27 GMT Subject: Re: Probable bug in file run-command.c function clear_child_for_cleanup Message-ID: <20120910141027.GA8284@sigill.intra.peff.net> In-Reply-To: On Mon, Sep 10, 2012 at 03:58:40PM +0200, Erik Faye-Lund wrote: > >> for (... { > >> if (... { > >> ... > >> } > >> last = &p->next; > >> } > [...] > I feel like bikeshedding a bit today! > > I tend to either prefer either the latter or something like this: > > while (p) { > ... > > last = p; > p = p->next; > } > > because those approaches put all the iteration logic in the same > place. The in-body traversal approach is a bit more explicit about the > traversal details. Also fine by me. > And to conclude my bikeshedding for the day: Shouldn't "last" ideally > be called something like "prev" instead? It's the previously visited > element, not the last element in the list. It is the "last" element visited (just as "last week" is not the end of the world), but yes, it is ambiguous, and "prev" is not. Either is fine by me. -Peff