From: Jonathan Nieder Date: Sun, 15 Apr 2012 21:37:18 GMT Subject: Re: [PATCH v2] completion: add new git_complete helper Message-ID: <20120415213718.GB5813@burratino> In-Reply-To: <1334524814-13581-1-git-send-email-felipe.contreras@gmail.com> Felipe Contreras wrote: > This simplifies the completions, and makes it easier to define aliases: > > git_complete gf git_fetch Sounds neat. Unfortunately users could already be using a function with some other purpose named git_complete in their .profile and this would override it. The completion script has so far stuck to a limited namespace: _git_* (completion functions) __git_* (everything else, including public interfaces like __git_ps1) A name like __git_complete should work, presumably. Hope that helps, Jonathan