From: Jonathan Nieder Date: Thu, 02 Feb 2012 11:16:28 GMT Subject: Re: [PATCH 1/3] vcs-svn: rename check_overflow arguments for clarity Message-ID: <20120202111628.GN3823@burratino> In-Reply-To: Dmitry Ivankov wrote: > On Thu, Feb 2, 2012 at 4:59 PM, Jonathan Nieder wrote: >> From: Ramsay Jones >> >> Code using the argument names a and b just doesn't look right (not >> sure why!).  Use more explicit names "offset" and "len" to make their >> type and function clearer. > > Well, it's still not clear. Given off_t a, size_t b, check that a+b > fits into type... which type? > "offset" and "length" don't imply that it's "type of offset" or maybe > "type of length". Hmm... in vector arithmetic, position (i.e., file offset) + displacement (i.e., size of chunk) = position (i.e., new file offset). Any ideas for making this clearer?