From: Jonathan Nieder Date: Sun, 08 Jan 2012 19:34:54 GMT Subject: Re: [PATCH 2/6] revert: decouple sequencer actions from builtin commands Message-ID: <20120108193454.GG1942@burratino> In-Reply-To: <1326025653-11922-3-git-send-email-artagnon@gmail.com> Ramkumar Ramachandra wrote: > So, while a future > instruction sheet would look like: > > pick next~4 > action3 b74fea > revert rr/moo^2~34 > > the actions "pick", "action3" and "revert" need not necessarily > correspond to the specific builtins. So what change does the patch actually make? Is this a renaming? [...] > --- a/builtin/revert.c > +++ b/builtin/revert.c [...] > @@ -64,16 +64,21 @@ struct replay_opts { > > #define GIT_REFLOG_ACTION "GIT_REFLOG_ACTION" > > -static const char *action_name(const struct replay_opts *opts) > +static const char *command_name(struct replay_opts *opts) Why is the const being dropped? I'm lost, so not reading further.