From: Jonathan Nieder Date: Tue, 21 Jun 2011 17:00:30 GMT Subject: Re: [PATCH 08/13] revert: Separate cmdline parsing from functional code Message-ID: <20110621170030.GM15461@elie> In-Reply-To: <1308661489-20080-9-git-send-email-artagnon@gmail.com> Ramkumar Ramachandra wrote: > Currently, revert_or_cherry_pick does too many things including > argument parsing and setting up to pick the commits; this doesn't make > a good API. Simplify and rename the function to pick_commits, so that > it just has the responsibility of setting up the revision walker and > calling do_pick_commit in a loop. Transfer the remaining work to its > callers cmd_cherry_pick and cmd_revert. Makes sense to me. :) > Later in the series, > pick_commits will serve as the starting point for continuation. This sentence is a little cryptic. The naive reader wonders "continuation of what?"