From: Jeff King Date: Fri, 20 May 2011 13:23:44 GMT Subject: Re: [PATCH 2/4] basic priority queue implementation Message-ID: <20110520132344.GA30616@sigill.intra.peff.net> In-Reply-To: On Fri, May 20, 2011 at 10:13:10AM -0300, Thiago Farina wrote: > > Speaking of naming, though, the real problem is that this data structure > > should be called "pqueue" or something similar to indicate that it is > > not a simple FIFO. Unfortunately, the short-and-sweet "pqueue" is taken > > by openssl, which pollutes all over the global namespace. > > > Hum, yeah when I read the commit message I though about the name of > the structure, but I didn't want to bother you with that. Probably you > have considered the option of naming it 'priority_queue' too. Haven't > you chose priority_queue, because you consider the name longer than > necessary? Exactly. Though unless somebody can come up with a practical case where using the priority queue speeds up some operation, I don't think it is worth applying anyway. So the naming question is somewhat academic. :) -Peff