From: Jonathan Nieder Date: Tue, 08 Feb 2011 10:26:05 GMT Subject: [PATCH v2 0/3] checkout: introduce --detach synonym for "git checkout foo^{commit}" Message-ID: <20110208102605.GA29660@elie> In-Reply-To: <20110208005238.GB24340@elie> Jonathan Nieder wrote: > Two of the new tests fail. :) ... and here's a reroll fixing them. Applies on top of the old uk/checkout-ambiguous-ref (0cb6ad3, 2011-01-11). Patch 1 is an irrelevant cleanup, for while I have your eyes on this code. :) Patch 2 introduces the --detach option, taking care to error out in special cases. Patch 3 is another cleanup, to make the effect of patch 2 more clear. Thanks again for your help. Jonathan Nieder (2): checkout: split off a function to peel away branchname arg checkout: rearrange update_refs_for_switch for clarity Junio C Hamano (1): checkout: introduce --detach synonym for "git checkout foo^{commit}" Documentation/git-checkout.txt | 13 ++- builtin/checkout.c | 265 +++++++++++++++++++++++---------------- t/t2020-checkout-detach.sh | 95 ++++++++++++++ 3 files changed, 262 insertions(+), 111 deletions(-) create mode 100755 t/t2020-checkout-detach.sh