From: Yann Dirson Date: Thu, 30 Dec 2010 10:49:08 GMT Subject: Re: [PATCH 1/6] Introduce sorted-array binary-search function. Message-ID: <20101230104908.GB3296@home.lan> In-Reply-To: On Thu, Dec 30, 2010 at 02:06:28AM +0100, Erik Faye-Lund wrote: > On Thu, Dec 30, 2010 at 1:40 AM, Yann Dirson wrote: > > On Fri, Dec 10, 2010 at 02:29:09PM -0800, Junio C Hamano wrote: > >> In addition, these macros in this patch are almost unreadable, but that > >> probably is mostly a fault of C's macro, not yours. > > > > Yes.  When writing those I sorely missed the readability of C++ > > templates - yuck :) > > Unfortunately, it's something that ends up subtracting from the value > of the change; a couple of duplicate functions is often easier to > maintain than nasty macros. Well, I don't find this one much less readable than, say, vcs-svn/trp.h At least the declare_gen_* ones are quite readable. Maybe making the macro names shorter would help clarify the convenience wrappers ?