From: Jeff King Date: Wed, 01 Dec 2010 21:07:42 GMT Subject: Re: [PATCH] add: introduce add.ignoreerrors synonym for add.ignore-errors Message-ID: <20101201210742.GA13740@sigill.intra.peff.net> In-Reply-To: <7vipzduufr.fsf@alter.siamese.dyndns.org> On Wed, Dec 01, 2010 at 12:09:12PM -0800, Junio C Hamano wrote: > We actually need to stress the fact that _only_ newer git will understand > "add.ignoreErrors", so people with older git (especially the ones who need > to use both older and newer versions of git) may need to keep using the > older form in their configuration, no? > > Perhaps phrasing it like this, and then issue v1.7.{0,1,2,3}.X maintenance > release to reduce the chance of inconveniencing the users? Yeah, I think it is better to be explicit. > add.ignore-errors:: > +add.ignoreErrors:: > Tells 'git add' to continue adding files when some files cannot be > added due to indexing errors. Equivalent to the '--ignore-errors' > - option of linkgit:git-add[1]. > + option of linkgit:git-add[1]. Older versions of git accept only > + `add.ignore-errors`, whose name goes against the convention, so > + newer versions of git honor `add.ignoreErrors` as well. Nit: Somehow "goes against the convention" doesn't sound quite right to me. Astute users can probably figure out which convention, but perhaps we should be more explicit like: Older versions of git accept only `add.ignore-errors`, which does not follow the usual naming convention for configuration variable. Newer versions of git honor `add.ignoreErrors` as well. -Peff