From: Jonathan Nieder Date: Sun, 14 Nov 2010 21:19:05 GMT Subject: Re: [PATCH] commit: Append commit_list prefix in two function names. Message-ID: <20101114211905.GB10150@burratino> In-Reply-To: <0b9cde68dcdfddc13a91a63f9deb3384576164de.1289768501.git.tfransosi@gmail.com> Thiago Farina wrote: > Append commit_lis prefix to insert_by_date function and to sort_by_date, > so it's clear that these functions refer to commit_list structure. Nits: by "Append" I think you mean "Add"; missing "t" after commit_lis. This gives the oft-used insert_by_name() function a fairly long name: commit_list_insert_by_name The proposed name is long enough to be unwieldly. It might have the virtue of fitting better with some of the commit_list lib: commit_list_count commit_list_insert free_commit_list Compare: sort_by_date pop_most_recent_commit sort_in_topological_order pop_commit Perhaps this change would work better if some of the others were renamed at the same time? Some notes on commit_lists in api-revision-walking.txt would do even more to make it intuitive. :) Hope that helps, Jonathan