From: Johan Herland Date: Mon, 01 Nov 2010 00:09:38 GMT Subject: Re: [PATCHv5 20/23] git notes merge: Add testcases for merging notes trees at different fanouts Message-ID: <201011010109.38459.johan@herland.net> In-Reply-To: <7vwrp16o21.fsf@alter.siamese.dyndns.org> On Friday 29 October 2010, Junio C Hamano wrote: > Subject: [PATCH] portability fix for [20/23] > > test "$(line generator | wc -l)" = $expected_number_of_lines (bad) > > is not portable, as "wc -l" can prefix the number with whitespaces. > > Either write the $(... | wc -l) without enclosing in a dq pair, i.e. > > test $(line generator | wc -l) = $expected_number_of_lines (good) > > or compare them numerically with > > test "$(... | wc -l)" -eq $num (ok) > > The former is preferred for readability. Ack. I'll fold this fix into the next iteration. Thanks! ...Johan -- Johan Herland, www.herland.net