From: Jonathan Nieder Date: Fri, 01 Oct 2010 11:45:14 GMT Subject: Re: [PATCHv4 15/15] Replace "unset VAR" with "unset VAR;" in testsuite as per t/README Message-ID: <20101001114514.GA18405@burratino> In-Reply-To: Elijah Newren wrote: > What do you think of the previous suggestions in this thread for a > portable_unset() function That sounds fine. Or if they are rare enough, one can use { unset FOO BAR BAZ || :; } > , or for using test_might_fail in front of > all these unset commands I fear this would make it harder for new readers to understand what test_might_fail does. But if a new function to run "foo || true" is needed, I wouldn't be opposed to adding one with a different name.