From: Jonathan Nieder Date: Sun, 18 Jul 2010 18:47:16 GMT Subject: Re: remove duplicate code and not needed break statement Message-ID: <20100718184716.GD14367@burratino> In-Reply-To: <1279475399-6081-1-git-send-email-ralf.thielow@googlemail.com> Hi Ralf! Ralf Thielow wrote: > Remove duplicate code and not needed break statement. This looks like a reasonable change, with the nice effect of getting read_pack_info_file() to almost fit in one screen. The commit message is not super clear. I would say: Subject: update-server-info: Shorten read_pack_info_file() The correct responses to a D and a T line in .git/objects/info/packs are the same, so combine their case arms. In both cases we already ‘goto’ out of the switch so while at it, remove a redundant ‘break’ to avoid yet another line of code. i.e., impact in the subject line, details in the commit message body. It is missing a sign-off. See Documentation/SubmittingPatches for what that means. Hope that helps, Jonathan