From: Thomas Rast Date: Tue, 13 Apr 2010 09:27:52 GMT Subject: Re: [PATCH v3 1/3] diff: add --word-diff option that generalizes --color-words Message-ID: <201004131127.52669.trast@student.ethz.ch> In-Reply-To: <7v8w8sljjr.fsf@alter.siamese.dyndns.org> Junio C Hamano wrote: > Thomas Rast writes: [...] > > + { DIFF_WORDS_COLOR, > > + {"", "", NULL}, > > + {"", "", NULL}, > > + {"", "", NULL}, > > + "\n" > > + } > > +}; > > Beautiful. > > The style might be a bit iffy. Shouldn't an opening "{", unless closed on > the same line with a matching "}", stand on its own line? Perhaps. OTOH I just noticed I could also drop the NULL (and let the implicit 0-padding take over) which makes every style fit on a single line. That should make it a bit easier to read. > > +static int fn_out_diff_words_write_helper(FILE *fp, > > + struct diff_words_style_elem st_el, > > Do you need to pass this by value? No, thanks for catching this. -- Thomas Rast trast@{inf,student}.ethz.ch