From: Thomas Rast Date: Thu, 04 Feb 2010 10:59:51 GMT Subject: Re: [PATCH] Typofixes outside documentation area Message-ID: <201002041159.51543.trast@student.ethz.ch> In-Reply-To: <7v636dr2hy.fsf@alter.siamese.dyndns.org> On Thursday 04 February 2010 06:31:05 Junio C Hamano wrote: > diff --git a/levenshtein.h b/levenshtein.h > index 0173abe..4105bf3 100644 > --- a/levenshtein.h > +++ b/levenshtein.h > @@ -2,7 +2,7 @@ > #define LEVENSHTEIN_H > > int levenshtein(const char *string1, const char *string2, > - int swap_penalty, int substition_penalty, > + int swap_penalty, int substitution_penalty, > int insertion_penalty, int deletion_penalty); > > #endif To save others the trouble of looking it up, too: This does change the name of the parameter, but it's only the declaration. The actual definition of the function starts with int levenshtein(const char *string1, const char *string2, int w, int s, int a, int d) { so it doesn't need a similar rename, and no uses of the parameter are affected. AFAICS all other changes are only in comments or strings and should be safe. -- Thomas Rast trast@{inf,student}.ethz.ch