From: David Aguilar Date: Fri, 15 Jan 2010 17:59:15 GMT Subject: Re: [PATCH 3/3] difftool: Use eval to expand '--extcmd' expressions Message-ID: <20100115175913.GA21106@gmail.com> In-Reply-To: <4B502A0C.50108@viscovery.net> On Fri, Jan 15, 2010 at 09:40:44AM +0100, Johannes Sixt wrote: > David Aguilar schrieb: > > - $GIT_DIFFTOOL_EXTCMD "$LOCAL" "$REMOTE" > > + (eval $GIT_DIFFTOOL_EXTCMD "\"$LOCAL\"" "\"$REMOTE\"") > > The new code is broken if $LOCAL or $REMOTE can contain double-quotes. How > about this alternative: > > eval $GIT_DIFFTOOL_EXTCMD '"$LOCAL"' '"$REMOTE"' > > which I find more readable as well. I'll resend a patch later today (can't quite right now, but will have time later). > What's the reason for the sub-shell? Do you want to protect from shell > code in $GIT_DIFFTOOL_EXTCMD that modifies difftool's variables? > > -- Hannes None, really, so we can do without that as well. Thanks for your notes, -- David