From: Christian Couder Date: Wed, 12 Aug 2009 05:15:38 GMT Subject: [PATCH 00/13] more changes to port rebase -i to C using sequencer code Message-ID: <20090812051116.18155.70541.chriscool@tuxfamily.org> These is just the current state of my work. Some patches have already been sent but are not yet in pu. Christian Couder (9): sequencer: add "--fast-forward" option to "git sequencer--helper" sequencer: let "git sequencer--helper" callers set "allow_dirty" rebase -i: use "git sequencer--helper --fast-forward" pick: simplify "error(...)" followed by "return -1" pick: rename "pick()" to "pick_commit()" pick: remove useless PICK_REVERSE => PICK_ADD_NOTE code pick: simplify bogus comment about commiting immediately pick: libify "pick_help_msg()" rebase -i: use "git sequencer--helper --cherry-pick" Stephan Beyer (4): sequencer: add "do_fast_forward()" to perform a fast forward revert: libify pick sequencer: add "do_commit()" and related functions sequencer: add "--cherry-pick" option to "git sequencer--helper" Makefile | 2 + builtin-revert.c | 293 +++++++------------------------------------ builtin-sequencer--helper.c | 298 ++++++++++++++++++++++++++++++++++++++++++- git-rebase--interactive.sh | 19 +-- pick.c | 232 +++++++++++++++++++++++++++++++++ pick.h | 14 ++ 6 files changed, 592 insertions(+), 266 deletions(-) create mode 100644 pick.c create mode 100644 pick.h