From: Jakub Narebski Date: Wed, 01 Jul 2009 07:41:39 GMT Subject: Re: [PATCHv8 1/7] gitweb: refactor author name insertion Message-ID: <200907010941.40641.jnareb@gmail.com> In-Reply-To: On Wed, 1 July 2009, Giuseppe Bilotta wrote: > On Tue, Jun 30, 2009 at 11:08 PM, Jakub Narebski wrote: >> # prints time in local timezone, from result of parse_date >> # in the following format: " (HH:MM +/-tz_offset)" or " (%H:%M %z)" >> # with "atnight" warning when 0 <= hour_local < 6 >> >> or something like that.  Or just >> >> # prints time in local timezone, from result of parse_date > > How about > > # prints time in local timezone, highlight night hours Or # prints local part of parse_date, highlight night hours It important, I think, to state that print_local_time takes result of parse_date as an argument. Nevertheless that is just nitpicking and bikeshedding. >>>>> +sub print_local_time { >>>>> +     my %date = @_; >>>>> +     if ($date{'hour_local'} < 6) { >>>>> +             printf(" (%02d:%02d %s)", >>>>> +                     $date{'hour_local'}, $date{'minute_local'}, $date{'tz_local'}); >>>>> +     } else { >>>>> +             printf(" (%02d:%02d %s)", >>>>> +                     $date{'hour_local'}, $date{'minute_local'}, $date{'tz_local'}); >>>>> +     } >>>>> +} > > -- > Giuseppe "Oblomov" Bilotta > -- Jakub Narebski Poland