From: Jeff King Date: Sat, 06 Jun 2009 22:09:16 GMT Subject: Re: [PATCH] diesys calls die and also reports strerror(errno) Message-ID: <20090606220916.GA30064@coredump.intra.peff.net> In-Reply-To: <7vtz2vnogt.fsf@alter.siamese.dyndns.org> On Fri, Jun 05, 2009 at 12:12:34AM -0700, Junio C Hamano wrote: > > Am I the only one who thinks that 'die_errno' would be a better name for > > this function? > > You are not alone. I did find diesys() unreadable, but simply did not > think of an obviously better alternative like you did. It was meant to be "die with system error code". But given two votes (and an implicit one from Thomas in his code), I am fine with die_errno. -Peff