From: Jeff King Date: Fri, 08 May 2009 02:00:37 GMT Subject: Re: Tests in Cygwin Message-ID: <20090508020037.GA1264@coredump.intra.peff.net> In-Reply-To: <4A030277.2000708@SierraAtlantic.com> On Thu, May 07, 2009 at 11:47:03AM -0400, Don Slutz wrote: > Here is a change back to using spaces. It also includes a change > to test for the code working. Squash on top. Maybe it is just me, but I think test_expect_success SYMLINKS,SANITY 'some description' ' the actual test ' is more readable than the space (since it keeps the number of single quoted chunks on the line down). Which should be as simple as: > -# prerequisites can be concatenated with '+' > test_have_prereq () { > - save_IFS=$IFS > - IFS=+ > - set -- $* > - IFS=$save_IFS > - for prerequisite > + for prerequisite in $(echo $*) > do > case $satisfied in > *" $prerequisite "*) +for prerequisite in $(echo "$1" | tr , ' ') Just my bikeshedding two cents, -Peff