From: Robin Rosenberg Date: Mon, 16 Mar 2009 21:25:00 GMT Subject: Re: [EGIT PATCH 02/10] Rename the objectsUrl in the nested HttpObjectDB to Message-ID: <200903162225.00347.robin.rosenberg.lists@dewire.com> In-Reply-To: <20090316202513.GS22920@spearce.org> måndag 16 mars 2009 21:25:13 skrev "Shawn O. Pearce" : > Robin Rosenberg wrote: > > It is used for looking at alternate objects, so name it such > > No SOB? > > But I disagree with this name change. Its pointing at the > objects directory of a repository. It may also be used to > point at an alternate when opening an alternate, in which > case it points at the alternate's objects directory. > > IMHO, objectsUrl is the right name for this. Ok, I missed the real reason in the comment. It is name hiding. objectsUrl is the name of another variable in the outer scope. -- robin