From: Shawn O. Pearce Date: Mon, 16 Mar 2009 14:13:29 GMT Subject: Re: [JGIT PATCH 3/3] Use a common skipObject method to avoid UNINTERESTING items Message-ID: <20090316141329.GL22920@spearce.org> In-Reply-To: <200903150125.56987.robin.rosenberg.lists@dewire.com> Robin Rosenberg wrote: > fredag 13 mars 2009 19:11:52 skrev "Shawn O. Pearce" : > > All cases are using the same logic to decide that we should skip > > this current object and not return it to the caller. A common > > implementation makes the code easier to follow, especially as it > > reduces the ugly line wrap involved in the loop body. > > Java conventions dictate that this method should be called shouldSkipObject. It > is a boolean method that actually does not itself skip any objects. > > I can amend that for you. Yup, amend away. shouldSkipObject is a much better name. Thanks. -- Shawn.